(PHP 5 >= 5.5.0, PHP 7, PHP 8)
Das DateTimeInterface wurde eingeführt, damit Parameter-, Rückgabe- oder Eigenschaftstyp-Deklarationen entweder DateTimeImmutable oder DateTime als Wert annehmen können. Es ist nicht möglich, dieses Interface in benutzerdefinierten Klassen zu implementieren.
Gemeinsame Konstanten, die es ermöglichen, DateTimeImmutable- oder DateTime-Objekte durch DateTimeImmutable::format() und DateTime::format() zu formatieren, sind in diesem Interface ebenfalls definiert.
Atom (Beispiel: 2005-08-15T15:52:01+00:00)
HTTP-Cookies (Beispiel: Monday, 15-Aug-05 15:52:01 UTC)
ISO-8601 (Beispiel: 2005-08-15T15:52:01+0000)
Hinweis:
Dieses Format ist nicht kompatibel zu ISO-8601, wird aber aus Gründen der Abwärtskompatibilität so belassen. Für ISO-8601-Kompatibilität sollte stattdessen DateTimeInterface::ISO8601_EXPANDED oder DateTimeInterface::ATOM verwendet werden (siehe ISO8601:2004 Abschnitt 4.3.3 Punkt d).
ISO-8601 erweitert (Beispiel: +10191-07-26T08:59:52+01:00)
Hinweis:
Dadurch, dass dieses Format immer ein Vorzeichen enthält, können Jahresangaben außerhalb des normalen Bereichs von ISO-8601 (
0000-9999) angegeben werden. Es stellt außerdem sicher, dass der Teil mit der Zeitzone (+01:00) mit ISO-8601 kompatibel ist.
RFC 822 (Beispiel: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (Beispiel: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (Beispiel: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (Beispiel: Mon, 15 Aug 2005 15:52:01 +0000)
RFC 7231 (seit PHP 7.0.19 und 7.1.5) (Beispiel: Sat, 30 Apr 2016 17:52:13 GMT)
RFC 2822 (Beispiel: Mon, 15 Aug 2005 15:52:01 +0000)
Genau wie DATE_ATOM
RFC 3339 EXTENDED Format (Beispiel: 2005-08-15T15:52:01.000+00:00)
RSS (Beispiel: Mon, 15 Aug 2005 15:52:01 +0000)
World Wide Web Consortium (Beispiel: 2005-08-15T15:52:01+00:00)
| Version | Beschreibung |
|---|---|
| 8.4.0 | Die Klassenkonstanten sind nun typisiert. |
| 8.2.0 |
Die Konstante
DateTimeInterface::ISO8601_EXPANDED
wurde hinzugefügt.
|
| 7.2.0 | Die Klassenkonstanten von DateTime sind nun in DateTimeInterface definiert. |