(PHP 5 >= 5.5.0, PHP 7, PHP 8)
DateTimeInterface was created so that parameter, return, or property type declarations may accept either DateTimeImmutable or DateTime as a value. It is not possible to implement this interface with userland classes.
Common constants that allow for formatting DateTimeImmutable or DateTime objects through DateTimeImmutable::format() and DateTime::format() are also defined on this interface.
since: '8.5',message: 'this method is obsolete, as serialization hooks are provided by __unserialize() and __serialize()',Atom (example: 2005-08-15T15:52:01+00:00); compatible with ISO-8601, RFC 3339, and XML Schema
HTTP Cookies (example: Monday, 15-Aug-2005 15:52:01 UTC)
ISO-8601-like (example: 2005-08-15T15:52:01+0000)
Note:
This format is not compatible with ISO-8601, but is left this way for backward compatibility reasons. Use DateTimeInterface::ISO8601_EXPANDED, DateTimeInterface::ATOM for compatibility with ISO-8601 instead. (ref ISO8601:2004 section 4.3.3 clause d)
ISO-8601 Expanded (example: +10191-07-26T08:59:52+01:00)
Note:
This format allows for year ranges outside of ISO-8601's normal range of
0000-9999by always including a sign character. It also ensures that the timezone part (+01:00) is compatible with ISO-8601.
RFC 822 (example: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (example: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (example: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (example: Mon, 15 Aug 2005 15:52:01 +0000)
RFC 7231 (since PHP 7.0.19 and 7.1.5) (example: Sat, 30 Apr 2016 17:52:13 GMT)
RFC 2822 (example: Mon, 15 Aug 2005 15:52:01 +0000)
Same as DATE_ATOM
RFC 3339 EXTENDED format (example: 2005-08-15T15:52:01.000+00:00)
RSS (example: Mon, 15 Aug 2005 15:52:01 +0000)
World Wide Web Consortium (example: 2005-08-15T15:52:01+00:00)
| Version | Description |
|---|---|
| 8.5.0 |
The DATE_RFC7231 and
DateTimeInterface::RFC7231 constants have been deprecated.
|
| 8.4.0 | The class constants are now typed. |
| 8.2.0 |
The constant DateTimeInterface::ISO8601_EXPANDED
was added.
|
| 7.2.0 | The class constants of DateTime are now defined on DateTimeInterface. |