(PHP 5 >= 5.5.0, PHP 7, PHP 8)
DateTimeInterface fue creada tanto como parametro de retorno, como para las declaraciones de tipo de propiedad puedan aceptar tanto DateTimeImmutable o DateTime como valor. No es posible que el usuario implemente esta interfaz en sus propias clases.
Las constantes comunes que permiten el formato de objetos DateTimeImmutable o DateTime mediante DateTimeImmutable::format() y DateTime::format() son también definidas en esta interfaz.
since: '8.5',message: 'this method is obsolete, as serialization hooks are provided by __unserialize() and __serialize()',
Atom (ejemplo: 2005-08-15T15:52:01+00:00); compatible con ISO-8601, RFC 3339 y XML Schema
HTTP Cookies (ejemplo: Monday, 15-Aug-2005 15:52:01 UTC)
Similar a ISO-8601 (ejemplo: 2005-08-15T15:52:01+0000)
Nota:
Este formato no es compatible con el ISO-8601, aunque se deja por razones de retrocompatibilidad. Use DateTimeInterface::ISO8601_EXPANDED, DateTimeInterface::ATOM en su lugar para que sea compatible con el ISO-8601. (ref ISO8601:2004 section 4.3.3 clause d)
ISO-8601 Extendido (ejemplo: +10191-07-26T08:59:52+01:00)
Nota:
Este formato permite rangos de años fuera del rango normal de ISO-8601 de
0000-9999al incluir siempre un carácter de signo. También asegura que la parte de la zona horaria (+01:00) sea compatible con ISO-8601.
RFC 822 (ejemplo: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (ejemplo: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (ejemplo: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000)
RFC 7231 (desde PHP 7.0.19 y 7.1.5)
(ejemplo: Sat, 30 Apr 2016 17:52:13 GMT)
RFC 2822 (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000)
Igual que DATE_ATOM
Formato RFC 3339 EXTENDED
(ejemplo: 2005-08-15T15:52:01.000+00:00)
RSS (ejemplo: Mon, 15 Aug 2005 15:52:01 +0000).
World Wide Web Consortium (ejemplo: 2005-08-15T15:52:01+00:00).
| Versión | Descripción |
|---|---|
| 8.5.0 |
Las constantes DATE_RFC7231 y
DateTimeInterface::RFC7231 han sido obsoletas.
|
| 8.4.0 | Las constantes de clase ahora están tipadas. |
| 8.2.0 |
Se ha añadido la constante
DateTimeInterface::ISO8601_EXPANDED.
|
| 7.2.0 | Las constantes de clase de DateTime ahora están definidas en DateTimeInterface. |