(PHP 5 >= 5.5.0, PHP 7, PHP 8)
DateTimeInterface は、 DateTimeImmutable や DateTime を引数や戻り値、プロパティの型宣言で使えるようにするために作られたものです。 このインターフェイスを実装したクラスをユーザー側で作ることはできません。
DateTimeImmutable::format() や DateTime::format() を通じて、 DateTimeImmutable や DateTime をフォーマットするための共通の定数も、 このインターフェイスに定義されています。
since: '8.5',message: 'this method is obsolete, as serialization hooks are provided by __unserialize() and __serialize()',Atom (例: 2005-08-15T15:52:01+00:00)。ISO-8601、RFC 3339、および XML Schema と互換性があります
HTTP Cookie (例: Monday, 15-Aug-2005 15:52:01 UTC)
ISO-8601 に似た形式 (例: 2005-08-15T15:52:01+0000)
注意:
このフォーマットは、ISO-8601 と互換性がありません。 しかし、後方互換性を保つために残されています。 ISO-8601 と互換性を保つためには、 DateTimeInterface::ISO8601_EXPANDED, DateTimeInterface::ATOM を使うようにしてください。 (ISO8601:2004 section 4.3.3 clause d も参照ください)
ISO-8601 拡張形式 (例: +10191-07-26T08:59:52+01:00)
注意:
年に常に符号を含めることで、ISO-8601 の通常の範囲
0000-9999以外の値が許されています。 タイムゾーンの部分 (+01:00) については、 ISO-8601 と互換性を保証するようにもなっています。
RFC 822 (例: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (例: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (例: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (例: Mon, 15 Aug 2005 15:52:01 +0000)
RFC 7231 (PHP 7.0.19 と 7.1.5以降) (例: Sat, 30 Apr 2016 17:52:13 GMT)
RFC 2822 (例: Mon, 15 Aug 2005 15:52:01 +0000)
DATE_ATOM と同じです
RFC 3339 EXTENDED フォーマット (例: 2005-08-15T15:52:01.000+00:00)
RSS (例: Mon, 15 Aug 2005 15:52:01 +0000)
World Wide Web Consortium (例: 2005-08-15T15:52:01+00:00)
| バージョン | 説明 |
|---|---|
| 8.5.0 |
定数 DATE_RFC7231 および
DateTimeInterface::RFC7231 は、推奨されなくなりました。
|
| 8.4.0 | クラス定数が型付けされました。 |
| 8.2.0 |
定数
DateTimeInterface::ISO8601_EXPANDED
が追加されました。
|
| 7.2.0 | DateTime クラスの定数は、 DateTimeInterface で定義されるようになりました。 |