以下の定数が定義されています。 この関数の拡張モジュールが PHP 組み込みでコンパイルされているか、 実行時に動的にロードされている場合のみ使用可能です。
Memcached::OPT_COMPRESSIONペイロードの圧縮を有効または無効にします。 有効にした場合、ある閾値(現状2000バイト)より長いアイテムは、 ストレージ内では圧縮され、取得時に透過的に伸長されます。 閾値は ini 設定 memcached.compression_threshold で調整できます。
Memcached::OPT_COMPRESSION_TYPE
圧縮を有効にする場合に、利用する圧縮アルゴリズムを指定します。
有効な値は、Memcached::COMPRESSION_FASTLZ,
Memcached::COMPRESSION_ZLIB,
Memcached::COMPRESSION_ZSTD です。
型: int, デフォルト: Memcached::COMPRESSION_FASTLZ
Memcached::COMPRESSION_FASTLZFASTLZ 圧縮アルゴリズム
Memcached::COMPRESSION_ZLIBZLIB 圧縮アルゴリズム
Memcached::COMPRESSION_ZSTDZSTD 圧縮アルゴリズム
Memcached 3.3.0 以降で利用可能です
Memcached::OPT_COMPRESSION_LEVEL圧縮が有効な場合に、圧縮レベルを指定します。
Memcached::COMPRESSION_FASTLZ は圧縮レベルをサポートしていませんMemcached::COMPRESSION_ZSTD: 最小レベルは -22 で、最大レベルは 22 ですMemcached::COMPRESSION_ZLIB: 最小レベルは 0 で、最大レベルは 9 です型: int, デフォルト: 3
Memcached::OPT_SERIALIZER
スカラーでない値をシリアライズする際に使う、シリアライザを指定します。
有効な値は Memcached::SERIALIZER_PHP,
Memcached::SERIALIZER_IGBINARY,
Memcached::SERIALIZER_JSON,
Memcached::SERIALIZER_JSON_ARRAY,
Memcached::SERIALIZER_MSGPACK です。
型: int, デフォルト: Memcached::SERIALIZER_IGBINARY が有効な場合は、Memcached::SERIALIZER_IGBINARY。
そうではなく、Memcached::SERIALIZER_MSGPACK が有効な場合は、
Memcached::SERIALIZER_MSGPACK。
いずれも有効でない場合は、
Memcached::SERIALIZER_PHP。
Memcached::SERIALIZER_PHPデフォルトのPHPのシリアライザ
Memcached::SERIALIZER_IGBINARYigbinary シリアライザです。 PHP のデータ構造を、テキスト表現の代わりにコンパクトなバイナリ表現で保存します。 その結果、保存スペースの節約と処理時間の短縮に繋がります。
このシリアライザは、memcached が --enable-memcached-igbinary オプションを使い、igbinary 拡張モジュールをロードした場合にのみサポートされます。
Memcached::SERIALIZER_JSONJSON シリアライザ。このシリアライザは、JSON をオブジェクトにアンシリアライズします
Memcached::SERIALIZER_JSON_ARRAYJSON 配列のシリアライザです。 このシリアライザは、JSON を連想配列としてアンシリアライズします。
Memcached::SERIALIZER_MSGPACK» MessagePack シリアライザです
このシリアライザは、memcached が --enable-memcached-msgpack
オプションを使い、msgpack
拡張モジュールをロードした場合にのみサポートされます。
Memcached::OPT_PREFIX_KEY
これを使うと、アイテムのキーに「ドメイン」を作成できます。
ここで指定した値がキーの名前の先頭に付きます。
128 文字より長くはできず、
ここで指定した値の分だけキーに指定できる長さが小さくなります。
プレフィックスが付くのはアイテムのキーだけであり、
サーバーのキーには付きません。
型: string, デフォルト: ""
Memcached::OPT_HASH
アイテムのキーに対するハッシュアルゴリズムを指定します。
有効な値は Memcached::HASH_*
定数にあります。
ハッシュアルゴリズムは、それぞれ利点と欠点があります。
よくわからない、または気にしない場合は、デフォルト値を指定しましょう
型: int, デフォルト: Memcached::HASH_DEFAULT
Memcached::HASH_DEFAULTThe default (Jenkins one-at-a-time) キーハッシュアルゴリズム
Memcached::HASH_MD5MD5 キーハッシュアルゴリズム
Memcached::HASH_CRCCRC アイテムキーハッシュアルゴリズム
Memcached::HASH_FNV1_64FNV1_64 キーハッシュアルゴリズム
Memcached::HASH_FNV1A_64FNV1_64A キーハッシュアルゴリズム
Memcached::HASH_FNV1_32FNV1_32 キーハッシュアルゴリズム
Memcached::HASH_FNV1A_32FNV1_32A キーハッシュアルゴリズム
Memcached::HASH_HSIEHHsieh キーハッシュアルゴリズム
Memcached::HASH_MURMURMurmur キーハッシュアルゴリズム
Memcached::OPT_DISTRIBUTIONアイテムのキーをサーバーに分散する方法を指定します。 現状サポートされている方法は、Module ベースと、 コンシステント・ハッシュです。 コンシステント・ハッシュの方がデータをうまく分散するので、 最小のキャッシュロスでクラスタにサーバーを追加できます
型: int, デフォルト: Memcached::DISTRIBUTION_MODULA
Memcached::DISTRIBUTION_MODULAModuloベースのキー分散アルゴリズム
Memcached::DISTRIBUTION_CONSISTENTコンシステント・ハッシュ キー分散アルゴリズム(libketama ベース)
Memcached::DISTRIBUTION_VIRTUAL_BUCKETVirtual Bucket hashing キー分散アルゴリズム(vbucket とも呼びます)
Memcached::OPT_LIBKETAMA_COMPATIBLElibketama 風の挙動との互換性を有効あるいは無効にします。 有効にすると、アイテムのキーのハッシュアルゴリズムは MD5、 そして分散方式は重み付きコンシステント・ハッシュになります。 これを使うと、他の libketama ベースのクライアント (Python や Ruby など) を同じサーバー設定で使え、キーも透過的にアクセスできるようになるので有用です。
注意:
コンシステント・ハッシュを使う場合は、 このオプションを有効にすることを強く推奨します。 将来のリリースでは、デフォルトでこのオプションは有効になるかもしれません。
Memcached::OPT_LIBKETAMA_HASHホストのマッピングに用いるハッシュアルゴリズムを指定します。
型: int
Memcached::OPT_TCP_KEEPALIVETCP の keep alive を有効にします。
Memcached::OPT_BUFFER_WRITESバッファ入出力を有効あるいは無効にします。 バッファ入出力を有効にすると、ストレージへのコマンドを送信する代わりに 「バッファ」に向けるようになります。 データを取得するアクションを実行すると、このバッファをリモート接続に送信します。 接続を終了したり閉じたりしたときも、バッファに入ったデータをリモート接続に送信します。
Memcached::OPT_BINARY_PROTOCOLバイナリプロトコルを有効にします。 接続を行う際に、このオプションは設定できない点に注意してください。
Memcached::OPT_NO_BLOCK非同期 I/O を有効にするか、無効にするかを指定します。 これを有効にすると、storage 関数に最速で転送できます。
Memcached::OPT_NOREPLYストレージへのコマンド (set, add, replace, append, prepend, delete, increment, decrement など) の実行結果を無視するか、しないかを指定します。 ストレージへのコマンドは、送信された後、応答を待つのに時間を使いません。 (応答がない場合もあります) Memcached::get() のように、 データを取得するコマンドは、この設定による影響を受けません。
Memcached::OPT_TCP_NODELAYソケットに接続する際に no-delay 機能を有効にしたり無効にしたりします (環境によっては高速になる場合があります)
Memcached::OPT_SOCKET_SEND_SIZEソケットの送信バッファの最大長をバイト単位で指定します
型: int, デフォルト: platform/kernel の設定によって変わります
Memcached::OPT_SOCKET_RECV_SIZEソケットの受信バッファの最大のバイト数
型: int, デフォルト: platform/kernel の設定によって異なります
Memcached::OPT_CONNECT_TIMEOUTノンブロッキングモードの際、 ソケット接続のタイムアウトをミリ秒単位で指定します
型: int, デフォルト: 1000
Memcached::OPT_RETRY_TIMEOUT接続が失敗した場合に、再試行まで待つ時間を秒単位で指定します。
型: int, デフォルト: 2
Memcached::OPT_DEAD_TIMEOUT
死んでいるサーバーに再試行まで待つ時間を秒単位で指定します。
0 は、リトライを行わないということです
型: int, デフォルト: 0
Memcached::OPT_SEND_TIMEOUTソケットの送信タイムアウトを、ミリ秒単位で指定します。 ノンブロッキングI/O を使えない場合、 この設定によってデータの送信タイムアウトを利用できます
型: int, デフォルト: 0
Memcached::OPT_RECV_TIMEOUTソケットの読み取りタイムアウトを、ミリ秒単位で指定します。 ノンブロッキングI/O を使えない場合、 この設定によってデータの読み取りタイムアウトを利用できます
型: int, デフォルト: 0
Memcached::OPT_POLL_TIMEOUT接続ポーリングのタイムアウト。ミリ秒単位
型: int, デフォルト: 1000
Memcached::OPT_CACHE_LOOKUPSDNS lookup のキャッシュを有効にするか、無効にするかを指定します
Memcached::OPT_SERVER_FAILURE_LIMITサーバーへの接続試行が、失敗する回数の上限を指定します。 継続して接続が失敗すると、サーバーはリストから削除されます
型: int, デフォルト: 5
Memcached::OPT_SERVER_TIMEOUT_LIMITサーバーへの接続試行のタイムアウト値を指定します。 継続して接続がタイムアウトすると、サーバーはリストから削除されます
型: int, デフォルト: 0
Memcached::OPT_AUTO_EJECT_HOSTS
無効にしたサーバーを一覧から削除します。
Memcached::OPT_SERVER_FAILURE_LIMIT や
Memcached::OPT_SERVER_TIMEOUT_LIMIT と一緒に使います。
注意:
このオプションは、
Memcached::OPT_REMOVE_FAILED_SERVERSに置き換えられました。
Memcached::OPT_VERIFY_KEYmemcached による、キーの検証を有効にします
Memcached::OPT_USE_UDPTCP の代わりに UDP を使います
Memcached::OPT_NUMBER_OF_REPLICAS各アイテムについて、ここで指定した数のレプリカを異なるサーバーに保存します
型: int, デフォルト: 0
Memcached::OPT_RANDOMIZE_REPLICA_READS読み取り専用のレプリカをランダムに選びます
Memcached::OPT_REMOVE_FAILED_SERVERS
無効にしたサーバーを一覧から削除します。
Memcached::OPT_SERVER_FAILURE_LIMIT や
Memcached::OPT_SERVER_TIMEOUT_LIMIT と一緒に使います。
Memcached::HAVE_IGBINARYigbinary シリアライザのサポートを利用可能にするかを指示します
型: bool
Memcached::HAVE_JSONJSON シリアライザのサポートを利用可能にするかを指示します
型: bool
Memcached::HAVE_MSGPACKMessagePack シリアライザのサポートを利用可能にするかを指示します
型: bool
Memcached 3.0.0 以降で利用可能です
Memcached::HAVE_ZSTDZSTD 圧縮アルゴリズムのサポートを利用可能にするかを指示します
型: bool.
Memcached 3.3.0 以降で利用可能です
Memcached::HAVE_ENCODINGMemcached::setEncodingKey() を使って、データの暗号化をサポートするかどうかを指示します
型: bool.
Memcached 3.1.0 以降で利用可能です
Memcached::HAVE_SESSION型: bool
Memcached 3.0.0 以降で利用可能です
Memcached::HAVE_SASL型: bool.
Memcached 3.0.0 以降で利用可能です
Memcached::GET_EXTENDEDMemcached::get(), Memcached::getMulti(), Memcached::getMultiByKey() の返り値に、 CAS トークン値も一緒に含めることを保証するフラグ
Memcached 3.0.0 以降で利用可能です
Memcached::GET_PRESERVE_ORDER
Memcached::getMulti() や
Memcached::getMultiByKey() の返り値が、
キーがリクエストされた順に返されることを保証するフラグ。
キーが存在しない場合、デフォルト値 null を取得します。
Memcached::RES_SUCCESS操作は成功しました
Memcached::RES_FAILURE何らかの形で操作が失敗しました
Memcached::RES_HOST_LOOKUP_FAILUREDNS lookup が失敗しました
Memcached::RES_UNKNOWN_READ_FAILUREネットワークデータの読み取りに失敗しました
Memcached::RES_PROTOCOL_ERRORmemcached プロトコル内のコマンドが正しくありません
Memcached::RES_CLIENT_ERRORクライアント側のエラー
Memcached::RES_SERVER_ERRORサーバー側のエラー
Memcached::RES_WRITE_FAILUREネットワークデータの書き込みに失敗しました
Memcached::RES_DATA_EXISTScompare-and-swap(CAS) に失敗しました: 保存しようとしたアイテムが、 最後に取得する前に変更されたということです
Memcached::RES_NOTSTOREDアイテムが格納されなかったが、その原因はエラーではありません。 これは通常、"add" や "replace" コマンドの要件を満たさなかったか あるいはアイテムが削除キューに入っていることを意味します
Memcached::RES_NOTFOUNDこのキーのアイテムが ("get" や "cas" の操作で) 見つかりませんでした
Memcached::RES_PARTIAL_READネットワークデータの読み取りに、一部失敗しました
Memcached::RES_SOME_ERRORS複数 get している間にエラーが発生しました
Memcached::RES_NO_SERVERSサーバーリストが空です
Memcached::RES_END結果セットの終端です
Memcached::RES_ERRNOシステムエラー
Memcached::RES_BUFFERED操作がバッファリングされました
Memcached::RES_TIMEOUT操作がタイムアウトしました
Memcached::RES_BAD_KEY_PROVIDED無効なキー
Memcached::RES_STOREDアイテムが保存されました
Memcached::RES_DELETEDアイテムが削除されました
Memcached::RES_STAT統計情報
Memcached::RES_ITEMアイテム
Memcached::RES_NOT_SUPPORTEDサポートされていません
Memcached::RES_FETCH_NOTFINISHED情報の取得が終わりませんでした
Memcached::RES_SERVER_MARKED_DEADサーバーが死んだとマークされました
Memcached::RES_UNKNOWN_STAT_KEY不明な stat key です
Memcached::RES_INVALID_HOST_PROTOCOL無効なホストプロトコルです
Memcached::RES_MEMORY_ALLOCATION_FAILUREメモリの確保に失敗しました
Memcached::RES_CONNECTION_SOCKET_CREATE_FAILUREネットワークソケットの作成に失敗しました
Memcached::RES_PAYLOAD_FAILUREペイロードに関するエラー: つまり、値を シリアライズ/復元 したり、圧縮/解凍 することができなかった ことを示します
Memcached::RES_AUTH_PROBLEMMemcached 3.0.0 以降で利用可能です
Memcached::RES_AUTH_FAILUREMemcached 3.0.0 以降で利用可能です
Memcached::RES_AUTH_CONTINUEMemcached 3.0.0 以降で利用可能です
Memcached::RES_E2BIGMemcached 3.0.0 以降で利用可能です
Memcached::RES_KEY_TOO_BIGMemcached 3.0.0 以降で利用可能です
Memcached::RES_SERVER_TEMPORARILY_DISABLEDMemcached 3.0.0 以降で利用可能です
Memcached::RES_SERVER_MEMORY_ALLOCATION_FAILUREMemcached 3.0.0 以降で利用可能です