(PHP 5 >= 5.5.0, PHP 7, PHP 8)
Интерфейс DateTimeInterface разработали, чтобы объявления типов параметров, значений возврата или свойств принимали как значение объекты классов DateTimeImmutable и DateTime. Реализовать интерфейс в пользовательских классах невозможно.
В интерфейсе также определили общие константы для форматирования объектов DateTimeImmutable и DateTime методами DateTimeImmutable::format() и DateTime::format().
Дата и время в формате стандарта Atom: 2005-08-15T15:52:01+00:00; формат совместим со стандартами ISO-8601, RFC 3339 и XML Schema.
Дата и время для установки с блоках данных cookies HTTP-протокола: Monday, 15-Aug-05 15:52:01 UTC
Дата и время в формате, аналогичном стандарту ISO-8601: 2005-08-15T15:52:01+0000.
Замечание:
Формат несовместим со стандартом ISO-8601, но остаётся по соображениям обратной совместимости. Для совместимости со стандартом ISO-8601 указывают константу DateTimeInterface::ISO8601_EXPANDED или DateTimeInterface::ATOM. См. пункт d раздела 4.3.3 стандарта ISO8601:2004.
Дата и время по стандарту ISO-8601 Expanded: +10191-07-26T08:59:52+01:00
Замечание:
За счёт включения знакового символа формат принимает диапазоны лет за пределами нормального диапазона стандарта ISO-8601 —
0000-9999. Формат гарантирует, что часть+01:00с обозначением часового пояса совместима со стандартом ISO-8601.
Дата и время по стандарту RFC 822: Mon, 15 Aug 05 15:52:01 +0000
Дата и время по стандарту RFC 850: Monday, 15-Aug-05 15:52:01 UTC
Дата и время по стандарту RFC 1036: Mon, 15 Aug 05 15:52:01 +0000
Дата и время по стандарту RFC 1123: Mon, 15 Aug 2005 15:52:01 +0000
Дата и время по стандарту RFC 7231: Sat, 30 Apr 2016 17:52:13 GMT. Константа доступна с PHP 7.0.19 и 7.1.5
Дата и время по стандарту RFC 2822: Mon, 15 Aug 2005 15:52:01 +0000
То же, что и DATE_ATOM
Дата и время по стандарту RFC 3339 EXTENDED: 2005-08-15T15:52:01.000+00:00
Дата и время в RSS-формате: Mon, 15 Aug 2005 15:52:01 +0000
Дата и время в формате W3C (англ. World Wide Web Consortium): 2005-08-15T15:52:01+00:00
| Версия | Описание |
|---|---|
| 8.5.0 |
Константы DATE_RFC7231
и DateTimeInterface::RFC7231 устарели.
|
| 8.4.0 | Константы класса стали типизированными. |
| 8.2.0 |
Добавили константу
DateTimeInterface::ISO8601_EXPANDED.
|
| 7.2.0 | Константы класса DateTime теперь определяются в интерфейсе DateTimeInterface. |