(PHP 5 >= 5.5.0, PHP 7, PHP 8)
DateTimeInterface arayüzü, bağımsız değişken, dönüş değeri veya özellik türü bildirimlerinde değer olarak DateTime veya DateTimeImmutable kullanılabilsin diye oluşturuldu. Bu arayüzü kullanıcı tabanlı sınıflarla gerçeklemek mümkün değildir.
Ayrıca, DateTimeImmutable ve DateTime nesnelerini DateTimeImmutable::format() ve DateTime::format() üzerinden biçemlemeye izin veren ortak sabitler de bu arayüz ile tanımlanabilir.
since: '8.5',message: 'this method is obsolete, as serialization hooks are provided by __unserialize() and __serialize()',Atom (örnek: 2005-08-15T15:52:01+00:00)
HTTP çerezleri (örnek: Monday, 15-Aug-2005 15:52:01 UTC)
ISO-8601 (örnek: 2005-08-15T15:52:01+0000)
Bilginize:
Bu gösterim ISO-8601 ile uyumlu değildir, fakat geriye uyumluluk için kaldı. ISO-8601 ile uyumluluk için bunun yerine DateTimeInterface::ISO8601_EXPANDED, DateTimeInterface::ATOM kullanılmalıdır. (bkz: ISO8601:2004 bölüm 4.3.3 bent d)
ISO-8601 Expanded (example: +10191-07-26T08:59:52+01:00)
Bilginize:
Bu biçim, her zaman bir işaret karakteri ekleyerek, ISO-8601'in normal aralığı olan
0000-9999dışındaki yıl aralıklarına izin verir. Ayrıca, bu zaman dilimi bölümünün (+01:00) ISO-8601 ile uyumlu olduğunu da belirtir.
RFC 822 (örnek: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (örnek: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (örnek: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (örnek: Mon, 15 Aug 2005 15:52:01 +0000)
RFC 7231 (PHP 7.0.19 ve 7.1.5'ten beri) (örnek: Sat, 30 Apr 2016 17:52:13 GMT)
RFC 2822 (örnek: Mon, 15 Aug 2005 15:52:01 +0000)
DATE_ATOM gibidir.
RFC 3339 uzun gösterim. (örnek: 2005-08-15T15:52:01.000+00:00)
RSS (örnek: Mon, 15 Aug 2005 15:52:01 +0000)
Dünya Çapında Web Konsorsiyumu (örnek: 2005-08-15T15:52:01+00:00)
| Sürüm: | Açıklama |
|---|---|
| 8.2.0 | DateTimeInterface::ISO8601_EXPANDED sabiti eklendi. |
| 7.2.0 | DateTime sınıf sabitleri artık DateTimeInterface üzerinde tanımlı. |